AP PDF to IMAGE Help

AP PDF to IMAGE Batch Converter Command Line Overview top next
AP PDF to IMAGE Batch Converter is a useful pdf tool, the converter produces fully functional IMAGE documents with text, pictures, graphics etc, using the original PDF document formatting.It does not need any software support, such as Adobe Acrobat, Acrobat Reader, etc.

AP PDF to IMAGE Batch Converter supports outputting result pages to be customized.You can select sevral pages document to convert,and even at the discretion of you to convert pages document. Such as "1,2,3","2-100" etc,more information,please reference to page range setting. It process the documents one after another, to ensure a output directory for each of them and placing all the finished files of the document into its corresponding directory.
AP PDF to IMAGE function and face:
(01) | It quickly convert PDF document to IMAGE format.
(02) | It supports batch PDF to IMAGE conversion.
(03) | It supports encrypted PDF file.
(04) | It supports outputting result pages to be customized.
(05) | It supports conversion of vector graphics into image files.
(06) | It supports multifarious image format,such as 'bmp','tiff','jpg','gif','png','pcx' etc.
(07) | It supports generate multipage tiff files.
(08) | It supports any resolution in the generated Image files.
(09) | It supports conversion into 1bit, 4bits, 8bits,4bits grayscale ,8tits grayscale and 24bits format image.
(10) | It supports multifarious compression of tiff image,such as LZW, JPEG,PACKBITS, CCITT Group3,CCITT Group4,RLE etc.
(11) | It converts drag and drop of files.
(12) | It supports Win98/ME/NT/2000/XP platform.
(13) | It can automatic view the image files after converted.
(14) | It allows you to preserve original document layout.
(15) | It is easy to use stand-alone application.
(16) | It does not require Adobe Acrobat or Reader support.
(17) | Automatic installation and configuration.
(18) | Adobe Acrobat 3.0, 4.0, 5.0, 6.0 compatibility.
PDF to IMAGE effect pictures
(1) Source PDF file | (2) Destination image file
http://www.adultpdf.com
Copyright 2000-2006 by adultpdf.com Inc. All rights reserved.


System Installation previous top next
Install AP Pdf to IMAGE Batch Converter Command Line
You can download the programe setup file which is a zip file from our site at first,then you only need to decompress setup file.After above working,you can use the program.


System Uninstallation previous top next
Uninstall AP Pdf to IMAGE Batch Converter Command Line
All neet to do for uninstallation are to delete the direcotry which place the program files.


Using AP PDF to IMAGE Batch Converter Command Line previous top next
This section describes the AP PDF to IMAGE Batch Converter Command Line application that are available to you when working with PDF documents.
AP PDF to IMAGE Batch Converter Command Line is very easy to use.All you need to do is to setup the pdf documents that you want to conver and ouput direcotryt,for hign-level you can setup other parameters command settings. More command settings please click here. The examples look like below.
Quick to use AP Pdf to Image Batch Converter Command Line.
pdftoimage -i "c:\mypdf1.pdf" -o "d:\my _ images_dir" | Extract c:\mypdf1.pdf to 'd:\my _ images_dir',it is to output 24bits jpg images.
pdftoimage -i "c:\mypdf1.pdf" 1,2,5-10 -o "d:\" -t bmp | Extract c:\mypdf1.pdf to d:\,it only contain pages 1,2,5 through 10 and ouput 24bits bmp images.
pdftoimage -i "c:\mypdf1.pdf" -i "c:\mypdf2.pdf" -o "d:\imgs" | Extract c:\mypdf1.pdf and c:\mypdf2.pdf to 'd:\imgsr'.
pdftoimage -i "c:\mypdfs even_pages" -o "d:\" -z 130 -v | Extract all even pages of the pdf files placed in 'c:\mypdfs even_pages' to 'd:\',it sets page zoom 130% and views result image files.
pdftoimage -r AAAAAAAAAAAAAAAA | Register the program.
NOTICE: Detail command setting.


Command line options previous top next
AP Pdf to Image Batch Converter Command line program is very easy to use.
All you need to do is to choose the pdf documents you intend to convert.
You may add the optimize parameters for convert.
Note:
<>--- required
[]--- optional
Usage:
pdftoimage.exe <-i <input> [pages range] > [-i <input> [pages range]-i ... ]>
[-o <output>][-z <page zoom>]
[-u <user password>] [-w<owner password>]
[-t <image type >] [-x <horizontal dpi>] [-y <vertical dpi>][-q <jpeg quality>]
[-b <color bits per pixel>][-c <tiff compression mode>][-r <register>]
[-g][-m][-v][-h][-?]
1. Input and Output Settings
-i <input> Source pdf files or directory which contains pdf files you want to convert.This parameter can appear several times,such as:
e.g. 1) pdftoimage -i "c:\my pdf_1.pdf" -i "c:\my2.pdf" -i "c:\my pdfs" -o "d:\mypdfs"
Extract pdf files which are 'c:\my pdf_1.pdf','c:\my2.pdf' and all pdf files placed in 'c:\my pdfs' to 'd:\mypdfs'.
[pages range] Indicate extract pages ranges from pdf files.The program supports the following pages range.
serial | parameter symbol | description
1 | ALL_PAGES | extract all pages
2 | FIRST_PAGE | extract first page
3 | LAST_PAGE | extract last page
4 | EVEN_PAGES | extract even pages
5 | ODD_PAGES | extract odd pages
6 | CUSTOM_PAGES | extract custom pages
Default is extract all pages,more custom pages range information reference to pages range setting.
e.g. 1) pdftoimage -i "c:\my pdf 1.pdf" FIRST_PAGE -o "d:\" Extract the first page of "c:\my pdf 1.pdf" to "d:\".
e.g. 2) pdftoimage -i "c:\my pdf 2.pdf" EVEN_PAGES -o "d:\" Extract all even pages of "c:\my pdf 2.pdf" to "d:\".
e.g. 3) pdftoimage -i "c:\mypdf3.pdf" 1,5-10,25- -o "d:\" Extract the pages 1,5 through 10,25 through end of "c:\mypdf3.pdf" to "d:\".
-o <output> | Set destination directory to output result html files,default same as input directory.
-z <page zoom > | It is to set page zoom value-from 50%-200%,default is 100%.
-v | It is to view the result image files after the pdf files have been converted.

2. Image Settings
-t <image type> It is to set the type of result image files. The program supports the following image type.
serial | parameter symbol | description
1 | "BMP" | bmp image file
2 | "PNG" | png image file
3 | "GIF" | gif image file
4 | "PCX" | pcx image file
5 | "JPG" or "JPEG" | jpg image file
6 | "TIF" or "TIFF" | tif image file
Default is to ouput jpg image files..
e.g. 1) pdftoimage -i "c:\mypdf.pdf" -o "d:\" -q 60
Extract all pages of "c:\mypdf.pdf" to "d:\", it is to output jpg image file and set jpg quality with 60.
e.g. 2) pdftoimage -i "c:\mypdfs" -o "d:\my gifs" -t GIF -b 8 -g
Extract all pdf files placed in "c:\mypdfs" to "d:\my gifs",it is to output 8bits grayscale gif image files.
-x <horizontal dpi> | It is to set the horizontal dpi.
-y <vertical dpi> | It is to set the vertical dpi.
-q <image quality > | It is to set the quality of jpg/jpeg, from 1 to 100.
-b <color bits per pixel> | It is to set the number of bits per pixel with 1,4,8 and 24, default is 24.
-c <tiff compression mode> It is to set the tiff compression mode. The program supports the following mode.
serial | parameter symbol | description
1 | "NONE" |
2 | "LZW" |
3 | "JPG" or "JPEG" |
4 | "PACKBITS" |
5 | "GROUP4" |
6 | "GROUP3" |
7 | "RLE" |
Default is CCITT Group4 compression for 1bit tiff, LZW compression for 4,8,24bits tiff.
e.g. 1) pdftoimage -i "c:\mypdf.pdf" -o "d:\" -t tif -m -g -b 8 -c packbits
Extract all pages of 'c:\mypdf.pdf' to 'd:\',it is to ouput 8 bits grayscale multipage tiff and the compression is 'PACKBITS'.
-g It is to set grayscale image.If you set grayscale image,the progrom only accept 4 or 8 bits colors,default to set 8bits colors image.
e.g. 1) pdftoimage -i "c:\mypdf.pdf" -o "d:\" -t bmp -g -b 24
The above command ignore parameter '-b 24',it sets 8bits grayscale bitmap and places all result bitmaps to 'd:\' automaticly.
-m | It is to set the multipage tiff.

3. Security Settings
-u <user password> | It is to set user password.
-w <owner password > | It is to set owner password.

4. Other Settings
-r <register> | It is to register program.
-h | It is to open the help file.
-? | It is to open the help file.
For example:
pdftoimage -i "c:\mypdf1.pdf" -o "d:\my _ images_dir" | Extract c:\mypdf1.pdf to 'd:\my _ images_dir',it is to output 24bits jpg images.
pdftoimage -i "c:\mypdf1.pdf" 1,2,5-10 -o "d:\" -t bmp | Extract c:\mypdf1.pdf to d:\,it only contain pages 1,2,5 through 10 and ouput 24bits bmp images.
pdftoimage -i "c:\mypdf1.pdf" -i "c:\mypdf2.pdf" -o "d:\imgs" | Extract c:\mypdf1.pdf and c:\mypdf2.pdf to 'd:\imgsr'.
pdftoimage -i "c:\mypdfs even_pages" -o "d:\" -z 130 -v | Extract all even pages of the pdf files placed in 'c:\mypdfs even_pages' to 'd:\',it sets page zoom 130% and views result image files.
pdftoimage -r AAAAAAAAAAAAAAAA | Register the program.


How to register previous top next
1. Demo version
You can free download a demo version at http://www.adultpdf.com/index.html

Limitations of the demo version:
You are allowed to process only up to 10 pages of each pdf files simultaneously.
2. Buy now
You can order AP Pdf to Image Batch Converter Command Line online. Click here to buy right now.
Single License - only $49.9,thanks for you support.
3. Technology support

Guarantee: We are committed to providing excellent products and support to our customers. If you are dissatisfied with a adultpdf product after your purchase, we will refund your money.

Privacy Policy: We will not give, sell or otherwise transfer your personal information to third parties. Unless you ask us not to, we will send occasional email about new products and releases.

Ongoing Open Dialog: Our customers are our most valuable resource. Please let us know how we can improve our products and we will try our best to implement your suggestions.

If you have some questions about registering our product(s),or programe bugs,or suggestions of our product(s),or suggestions of our site,we will welcome you to contact us.
Our sales email: sales@adultpdf.com
Our support email: support@adultpdf.com
http://www.adultpdf.com
Copyright 2000-2006 by adultpdf.com Inc. All rights reserved.


Copyright previous top
"AP Pdf to Image Batch Converter Command Line " Software License

1. License.
AP Pdf to Image Batch Converter Command Line software ("the Software"), documentation accompanying this License on any media or in any form are licensed, to you by adultpdf.com Inc. adultpdf.com Inc. retains title to the Software. The Software and any copies which this License authorizes you to make are subject to this License.

2. Authorized Use and Restrictions.
This License allows you to install and use the Software on less than or up to the number of computers you have purchased the License for. If you purchased a License for one CPU, you may use the Software on only one machine at a time. A multi-processor computer is considered as one CPU for the purpose of this License. If you purchased the unlimited License, you may use the Software on anyone machine at any time and distribute the product to all your customers. You may not decompile, reverse engineer, disassemble, rent, lease, loan, distribute(not unlimited License), or produce derivative works from the Software. You may transfer your rights under this License provided that you transfer the related documentation, this License and a copy of the Software to a party who agrees to accept the terms of this License and destroy any and all copies of the Software in your possession. This License will terminate automatically without notice from adultpdf.com Inc if you fail to comply with any term(s) of this License.

3. Limitation of Liability.
UNDER NO CIRCUMSTANCES, INCLUDING NEGLIGENCE, SHALL adultpdf.com INC. BE LIABLE FOR ANY INCIDENTAL, SPECIAL, INDIRECT OR CONSEQUENTIAL DAMAGES ARISING OUT OF OR RELATING TO THIS LICENSE. SOME JURISDICTIONS DO NOT ALLOW THE LIMITATION OF INCIDENTAL OR CONSEQUENTIAL DAMAGES, SO THIS LIMITATION MAY NOT APPLY TO YOU. IN NO EVENT, adultpdf.com Inc.'S TOTAL LIABILITY TO YOU FOR ALL DAMAGES EXCEED THE AMOUNT YOU PAID TO adultpdf.com Inc. OR ITS AUTHORIZED DISTRIBUTOR.

4. Complete Agreement
This License constitutes the entire agreement between the parties with respect to the use of the Software and supercedes all (if any) prior or contemporaneous understandings. No amendment to or modification of this License will be binding unless in writing and signed by an authorized officer of adultpdf.com Inc.

--- end ---
http://www.adultpdf.com
Copyright 2000-2006 by adultpdf.com Inc. All rights reserved.


Page range overview top
The system supports to customize pages.You can select sevral pages document to convert,and even at the discretion of you to convert pages document. Such as "1,2,3","2-100" etc,more information reference to the following.
Page range | Description
2 | Extract page number 2 into pdf document.
2,7 | Extract pages 2 and 7 into pdf document.
1-9 | Extract pages containing pages 1 through 9.
-3 | Extract pages containing pages 1 through 3 .
5- | Extract pages containing pages 5 through end.
1,5-20,25,30- | Extract pages containing pages 1,5 through 20, 25 and 30 through end.